Forum Navigation
Please or Register to create posts and topics.

Engine Start Switches Sticking in FSX

(Original thread started on 08-11-09 by Eric Tomlin)

Simulator: FSX

Issue Brief: Engine Start Switch remaining in START or returning to START

3rd Party Mods/Name?: Yes-Friendly Panels

Airfile or Model Mods?: Yes, various performance tweaks.

 

ISSUE:

I have the L Eng tied to offset 0892 bit 1 and the R Eng tied to 092A bit 1 for starting the engines. In FS9, the sequence set through my FDS hardware is to press and release the momentary button and the engine starter runs for approx 18 seconds which gives it time to fire off and spool up before the starter cuts out. This is an autostart and it works perfect in FS9 and on both engines with no issues regardless if you start L or R first. However, in FSX one of the start switches in the software of the default LJ45 always sticks, meaning that it refuses to release the starter until I mouse click on the engine start panel, and of course this causes a START message to appear in amber on the EICAS of the P1000 software.

 

Does anyone else use the same offsets above to start their engines in FSX and have a similar issue?

 

UPDATE:

I tested this again last night and my results were just as crazy and random as before. Remember this is only in FSX using the same identical offsets that work perfect in FS9:

 

Upon starting the Right engine first, all was well and the starter didn't hang in the START position on the bitmap panel. I then started the L engine and had good luck there too. No restart attempt by the sim. However, after shutting down the airplane and trying it all over again, it pulled the same stunt where the START switch turned on one engine and remained on until I turned it off with the mouse. It's like FSX has some sort of weird scheme that holds onto some aspects or records of operation incorrectly. If you just read this and it sounds familiar to my Service Ticket post regarding Battery and Avionics, don't fret. I just copied and pasted that part because yes, it's going the same strange direction here. I have even shut down the aircraft once and when I went to restart (yes, using the same offsets) it started BOTH engines at one time, like an FSX autostart (Control+E). However, I only pressed the Right Eng Start button. What is making this such an issue for FSX?!

 

(Posted by Dave Ault on 08-12-09)

I posted this on Pete Dowsons FSUIPC site and he is sorting it out for me. For anyone else who needs this offset, here is Pete's reply:

 

Quote:

So I'll add them in the interim FSUIPC4 update planned for later today. I'll add these to the TURB ENG set of values, as follows:

208C (4 bytes) Turb eng 1 ignition switch, 1=on 0=off

218C (4 bytes) Turb eng 2 ignition switch, 1=on 0=off

228C (4 bytes) Turb eng 3 ignition switch, 1=on 0=off

238C (4 bytes) Turb eng 4 ignition switch, 1=on 0=off

 

(Posted by Eric Tomlin on 08-12-09)

What I'm wondering is this: The ignition switch is automatic on the LJ45 and I honestly can not find a situation where it's documented where we would ever touch that switch. However, you got some work done on this and I wanted to know what you were using it for?  I'm having 3 different mixed up issues with the engines starting in FSX and it's driving me nuts.

 

Example 1: You press either L or R Engine Start and that engine shows START on the EICAS and begins the spool process and eventually fires off and settles. This is the 'Normal and Correct' procedure that works fine each and every time in FS9 using offset 0892 bit 1 OR 4 (L engine or #1) and offset 092A bit 1 OR 4 (R engine or #2). However, in FSX this is not the usual case (using these offsets and bits). I then get Examples 2 and 3-

 

Example 2: You press either L or R Engine Start and that engine shows START on the EICAS and begins the spool process and eventually fires off and settles. This is where things get crazy in FSX. All of a sudden after the selected engine is started the OPPOSITE engine is now starting without any command/hardware being touched at all. What's with this? A few seconds later both are running fine but START is displayed on one of the two engine start switches, and it's sometimes the first engine you started BUT sometimes it's the 2nd engine that was started automatically via voodoo magic.

 

Example 3: You press either L or R Engine Start and that engine shows START on the EICAS and begins the spool process and eventually fires off and settles. The selected engine starts and then you start the next remaining engine (L or R) and for some reason the START command has illuminated again without any intervention via hardware. To get rid of it you must now reveal the panel since I have a full size cockpit and turn off the Start Switch via mouse.

 

What is most frustrating about this is not the fact that I realize FS9 and FSX behaive differently, but in that I get different results ( 1 of the examples above) each and every time. Why is it different?

 

I have considered deleting my default flight situation and reverting to the original FSX default flight situation and seeing if having that setup will 'correct' anything I've messed up. I do know that the F1 PC-12 had a requirement for you to first load up the default C182 in order to properly start up the Pilatus. Thanks for reading this, it's very frustrating when it works perfect in FS9 but not FSX.

 

UPDATE:

The saga continues, but there's now light at the end of the tunnel. I have finally determined how to successfully start the aircraft the proper way in FSX, and the limitations that are imposed by having your hardware set up correctly. Basically, I can reliably start up my engines in FSX using the correct Learjet-specific auto start (meaning you press the desired engine's momentary start button) and release and it starts up just fine. However, for some reason FSX will only let me do this correctly the FIRST time. If I shut the engines down and try this again, it won't work correctly. This is the bug, and I can not figure out why it's like this but it just is. When trying to start once again after shutting down, this is when the very same procedure attempted the first time goes wrong- for some reason FSX likes to start the engine but then go through the start procedure again, effectively keeping the start switch for that engine ON indefinitely until you open that bitmap panel in FSX and turn it off via mouse. This bites for those who like me, like to fly into an airport, shut 'her down, and then restart 5 minutes later like in real life. Ain't gonna happen without either some fix or ending the flight/FSX and reloading a new flight at the desired airport. If anyone can find a fix please post. Otherwise, I am now happy that it's halfway resolved.

 

UPDATE:

I couldn't leave well enough alone and I tried to resolve it by adding a 3rd function to the Auto Start for each engine and I discovered yet another surprise. In the InterfaceIT software (which is amazing BTW) I have the following:

 

Function 1: On/Down- Start {Engine 1 or 2} as a toggle that holds for a value of X seconds until light off (since it's a momentary)

 

Function 2: On/Down- Generator {Engine 1 or 2} (Comes online once N1 reaches a certain RPM, just like the real LJ)

 

...and I attempted to get rid of the dreaded START again that happens mysteriously after shutting down and restarting later by adding a function 3

 

Function 3: On/Down- Start= bit '0' .

 

Guess what? It actually WORKED on engine 1 where I could start Engine 1 (L), shut it down and restart time and time again and the start would not attempt to continue on it's own with this added function BUT for some reason Engine 2 (R) was not affected by the same added function. I have one more trick up my sleeve to try, but I doubt it will get rid of the incessant start issue for Engine 2 (R).

 

(Posted by Scott Wagner on 08-14-09)

Are you resetting engines to "Full Rich" before restarting?

 

(Posted by Eric Tomlin on 08-14-09)

Hey Scott, yes I am.

 

(Posted Eric Tomlin on 01-11-12)

Okay, I am very excited to report that this issue has been resolved. Way back when I first encountered the issue of the Engine Start sequence being messed up in FSX, I contacted Pete Dowson. He stated that there was a similar issue in the FSX 737 engine start sequence. A short time later he posted that he thought he found the issue and released an updated version of FSUIPC 4.x. To be honest, I forgot all about his suggestion of trying the latest version of FSUIPC. This week, while contemplating LM's Prepar3D, I decided I should fire up FSX and install the newest version of FSUIPC. Voila! Now the engine start sequence in FSX is working very well and I can actually bring myself to consider using FSX again.

 

(Posted by Eric Williams on 01-11-12)

That is fantastic news. I just saw your demo. Stellar work!

 

(Posted by Alan Norris on 02-02-15)

I just stumbled on this thread. I have an issue both in FSX and Prepar3d Version 1 whereby sometimes (and it seems to be random) pressing the start switch causes the START and IGN messages to appear on the EICAS but stay on after the engine has spooled up. Is this the same issue you were describing at the start of this thread and do you have a fix for it? I haven't updated FSUIPC for a while now (I need to do that soon).

 

(Posted by Ron Rollo on 02-02-15)

Thank you very much for finding this old thread Alan! I actually just logged this discrepancy in my Aircraft Discrepancy Log book as something that has bugged me for the past three years. I guess when Eric was working on this I was not paying attention because I did not have my computers running yet.

 

So it looks like I need to update FSUIPC........? But wait...... Eric posted his fix on 01-11-2012. I first purchased FSUIPC on 08-17-2012. You would think I have the version with this fix in it already. I found this in Peter's FSUIPC update Version 4.57 (January 2010):

 

"Fixed a long-standing bug in the jet engine starter facilities provided via offsets 0892 etc. Due to a misunderstanding about how the parameter to the TOGGLE MASTER STARTER SWITCH control operated, on certain occasions the wrong starter valve might be toggled when the starter lever is moved from CutOff to Idle."  I wonder if Eric was still using that third function in InterfaceIT?

 

"Function 3: On/Down- Start= bit '0' ."

 

One quick thing that I saw Eric wrote back in 2009:

"The ignition switch is automatic on the LJ45 and I honestly can not find a situation where it's documented where we would ever touch that switch."

 

Actually, I have learned over the past few years that you can and should select the IGN switches if your taking off or flying in heavy rain or moisture. This way it ensures you do not have an engine flare out on you. We learn as we go!

 

(Posted by Mark Speechley on 02-04-15)

Wow, more times that not I have to bring up the 2D fuel panel in P3D to unclick the IGN and Start buttons.  Would really make a big difference for a hardware cockpit not having to rely on the keyboard and mouse still.

 

I must also start up an Aircraft Discrepancy Logbook. I keep getting recurring things that continually crop up that I think are just unique to me but it seems may be not. Maybe a thread solely related to 'glitches' should be started and everyone can put in their problems and we can compare notes if common or not.

 

(Posted by Ron Rollo on 03-02-15)

Shane and I have been kicking around some ideas about how to fool the sim into making sure the STARTER for both engines turn off, especially after the second time we try to start up the engines. Here is what I came up with:

 

1. First off, I am in the process of switching over to P3D and I am using USB WIFI connections for all three computers. This I believe (along with Greg Branch) is an issue in reference to the way the computers communicate with one another and I am now in the process of switching over to LAN lines (Cat5e Ethernet cables) to connect the three computers together and also to the internet. This should eliminate any lag, stutters and miss information that I am currently seeing.

 

2. The part you will find interesting. For each Engine Start there are two functions in InterfaceIT. One is related to the "Start Engine(s)" and the other is related to the "Generator(s)". The one that we are interested in is the "Start Engine" function and it looks something like this:

 

Function 1: On/Down- Start {Engine 1 or 2} as a toggle that holds for a value of X seconds until light off (since it's a momentary)

 

Mine is set up so that X = 18000, which is a value of time that must pass. At that point in time, the selected engine lights off and the START on the MFD and START switch LED on the engine panel goes out, (suppose to anyway). In other words the illumination and indicators hold for about ten seconds and then they go out, or at least they should. I found that about 50% of the time they go out after the second set of left and right engine starts.

 

So what I am doing is a test that you might try for yourself and report back here in this thread. What I have done is created a third function that mirrors function #1 in all aspects except X = 18001. In other words, this third function acts like a safety net to turn off the STARTER a millisecond later in case the first function missed the trigger at 18000. You can play around with the X = value. I tried 18500 and then 18010. All three appear to work but the further away the X = value is from 18000, it seems to cause a "blink" of the START in the MFD.

 

As of right now I am using a value of 18001 and it seems to work fine. I have done about five engine shut downs and engine starts and so far the starters have not got stuck in the ON or START position. Further testing is needed and to be honest, I first need to get all three computers hardwired to the router via cat5e rather than WIFI. Give it a try and let use know your results!

 

(Posted by Alan Norris on 03-06-15)

Ron, thanks for that tip. I'm not sure why the START and GEN lights stay on but this is a good work around. Did you do the same for the GEN AML as well as I find that if START lights say on then the GEN light does too?

 

I'm also surprised that you have been using USB WiFi to connect your computers. IIRC when I (and you) were having issues with running only two computers, you suggested using CAT 6 cables which inferred that you were using a switch.

 

(Posted by Ron Rollo on 03-06-15)

Hey Alan, yes, I was using cat7 cable and a switch. But now that I have switched over to P3D and reformatting, it seems that my computers want to use the WIFI rather than using the hard wires within the small isolated network.

 

I get back in town tomorrow night and I should have a few hours to complete setting up all three computers to the router and of course one wired network. That way the computers have no choice.

 

UPDATE:

After setting up the extra line in InterfaceIT as described above in post #18, it seems that the sticking starter is resolved. I have started up and shut down the engines more than I could count and so far, no sticking starter to report. There have been a few times that the engines start up and you would expect the START to extinguish but it takes an extra second. This may be where the extra line is acting like a safety net and catching it in case the first line misses it.

 

I also have all three computers linked together now with Ethernet cable and a switch. Things are still lagging and I suspect now I need to make sure all my allowances and firewalls are set correctly. I have check ten times but I am still missing something somewhere. Both RMUs want to drop off after a bit of time. But that's for another thread.

 

(Posted by Ron Rollo on 09-23-16)

The other day I played around with the additional line of code in the START switch to fix the sticking START on the EICAS. As you may know, the additional line set a few milliseconds later resolved the issue of the sticking start after a restart, however, I found that it created a second problem. The START fix was causing at least the left generator to kick off about ten seconds later. When I removed the second line from the START switch, the generator problem went away.

 

So I think what I need to do is spend a little time trying a few different things to see if I can find a solution that resolves the sticky start switch and does not have an adverse effect on the generators. Fun stuff.


Comments are closed, but trackbacks and pingbacks are open.