Forum Navigation
Please or Register to create posts and topics.

AP APP Not Working Properly in FSX

(Original thread started on 12-28-10 by Jaap)

Recently I have updated my sim to FSX, but so far it's not going too well. I use Project Magenta MCP, CDU and PMRJ and the FSX Learjet 45.

 

First I noticed that when on Auto throttle (A/T), my hardware Throttles will still accept inputs. When I slide them to full, the engines spool up, after which the A/T tries to correct. Sometimes the N1 differences between the two engines are so big that it would severely yaw. All in all when on A/T, the aircraft behaves very nervous! This was never the case in FS9, I could slide the throttles back and forth, but nothing would happen....

 

But the bigger problems arise when lining up for landing:

Autopilot and A/T engaged, ILS freq. and headings entered.  As soon as the localizer becomes active, I hit APP, and the aircraft starts to line up with the runway.

 

At that point I'm about 10 miles out at a speed between 160 and 140 knots, Glideslope bug slowly starts going to the center, but as soon as it's there the aircraft goes nose up and picks up speed, and then slowly starts down at a speed of 800-900 ft per minute. But at that time I'm already way above glideslope, and the aircraft does nothing to correct it.

 

This is so bad that when I let the aircraft continue on it's present path, it would touch down way behind the runway, only before that, APP mode disconnects. So there's definitely something wrong. So far I have tried the following after extensive searches on the Internet:

 

-Removed all references to the autopilot from the panel config because it seemed PM did not have total control over the AP. Didn't help...

 

-Did all kinds of fiddling with the PM MCP ini and CDU.ini files. Didn't help

 

-Removed the FSX Lear45 and put the FS9 Lear45 in. Didn't help.

 

-Tried all kinds of approaches on different airfields, different speeds, press the APP button earlier, later etc. etc. It all won't work.

 

As an example, I tried a landing at KJFK and that went wonderfully well. When I tried Amsterdam, Rotterdam, Frankfurt, it went horribly wrong again. One difference to note is KJFK is a default Airport and the others are all Aerosoft Payware addon airports.  I'm out of options....Anyone have suggestions?

 

(Posted by Eric Tomlin on 12-28-10)

The airport should have nothing to do with it unless the Glideslope is offset incorrectly at those airports. At any rate, I'm not too surprised that you are having issues with the PM MCP and the LJ45 since it's not intended to work together unless they' have updated the MCP software lately. Also, don't forget the LJ45 has no autothrottle. That may have a contribution effect on your issues.

 

(Posted by Jaap on 12-29-10)

Hi Eric, you have to admit that it is strange that in FS9, I never had any of these problems with Autopilot, A/T and PM MCP. I know that the Lear45 does not have an Autothrottle like the way I use it, but it is still strange that the throtllehandles accept any input when on Autopilot. But I'll keep on trying and testing. FSX does look a lot better though, therefore I would pity it if because of above problems I would have to go back to FS9.

 

(Posted by Eric Tomlin on 12-29-10)

Good points Jaap. I am thrown off by the fact that it's working okay in FS9 but not FSX and the fact that others don't have that issue either. Maybe you could share the offsets/settings that you are using for throttle inputs and compare to others?

 

(Posted by Jaap on 12-29-10)

Hey Eric, I only read offsets from FSX for my Throttle to let the servo's move. For testing purposes, the servo's are now disconnected. The Inputs come from normal Joystick pots, calibrated via FSUIPC, so nothing exotic there.

 

I have been testing some more. Started only my main FS computer with GoFlight and set GoFlight MCP to FSDefault. Next I restored the original FSX Lear45 and started the flight from EHAM to EHRD. ILS set to Rwy 24, course 239. Alt set to 3000ft and speed to 220 knots. Started at EHAM Rwy 18L heading set to 180. Lifted of and at 400 ft, activated Autopilot and Speed. Aircraft behaves perfect climbs to and stabilized at 3000ft, speed kept at 220. Intercepted the ILS and pressed AP.

 

Aircraft turns nicely to heading 239 for EHRD Rwy 24. Set speed to 180 and glideslope starts to move. At GS capture point the Aircraft starts nose down, following the Glideslope exactly. Reduced speed further to 140 and selected flaps 8. Five miles out, set speed to 125 and select flaps 20. Glideslope and speed still perfect. 2 miles out select gear down and flaps 40. Speed nicely at 125 knots and touched down perfect at EHRD with no problems whatsoever.

 

Tried exactly the same with my full config active: PMRJ Captains and 1St Officer side, PM CDU with with all flight data entered and PM MCP controlling the Auto Pilot: Flight all screwed up. Far above glide slope and no safe touchdown even possible. I'm afraid you are right about PM not working together with FSX somehow. I think I'll have to send an mail to PM support and hope they can do something about this.

 

UPDATE:

Well, they don't. They say there's a bug in FSX Glideslope system and that it's not really a PM Issue to solve. But tell me this: How come FSX standard planes flown from 2D or 3D cockpit have no issue at all?  I'll keep testing!

 

(Posted by Alaxus on 12-30-10)

PM is oblivious to what either version of flight sim is doing. PM uses FSUIPC to get and send all the information. If FS is outputting the wrong information into FSUIPC then PMMCP will behave accordingly. This may be a question to ask on the Pete's FSUIPC forum.

 

NOTE: FSX made a monumental change on how external programs interact with it as compared to the previous version of FS9.

 

Another thing, try disabling the default FSX AP in your aircraft config file. They may be conflicting.

 

(Posted by Jaap on 12-31-10)

I had an email exchange with Jonathan Richardson and he clearly stated again that this bug is in FSX and due to the random nature of this bug they never found a solution for it.

 

I asked:

How come the following:

FSX running on Main PC, PM MCP running on separate PC, connected via WideFS.

FSX in Boeing 737 cockpit, engines running, cockpit alive.

 

When Turning or Pushing any MCP knob on the FSX cockpit, NOTHING happens on the PM MCP. Shouldn't the two be connected via FSUIPC?

 

No not at all. Neither one is interested in the other - don't use this as any kind of reference you don't even need a panel at all.

 

PM MCP reading data from FSUIPC offsets, triggered by turning or pushing a knob on the FSX cockpit?

 

As above.

The other way around: Turning or Pushing knobs on the PM MCP screen only has partial effect: HDG works, CRS works SPD works, but Altitude, Speed button, A/T button do not?

 

You will go around in circles with this approach.

 

I am 100% sure that the two PC's are connected, latest versions of FSUIPC and Widefs running so that SHOULD not be the problem. What's wrong then? I don't know and it's making me nuts!

 

The glide slope issue with FSX has been known about for years. To date no fix for FSX.

 

So, there you have it. Microsoft leaves us in the cold.  Anyway I found some workaround on the Net, exactly like you say in your post above Alaxus: Remove all references to the Autopilot from the Panel.cfg. I removed everything but the default view from it and for the last 5 approaches I did it went well.

 

To get my throttles moving again (by servo) I still had to assign a button via FSUIPC to activate the Speed button in FSX. When I did that it worked OK, strangely enough (because I removed all gauges from the panel...). That being said, the possibility to encounter the GS bug still exists. I think it's strange that none of you never seem to have encountered it. Ah well, when it happens I'll just treat it like an aircraft systems failure and fly in by hand!

 

(Posted by Ron Rollo on 09-13-13)

Now that my sim is up and running I have also discovered that the glideslope is not working properly when APP is selected. When it is said to "disable the autopilot in the config file" exactly how do we go about doing that? Are we disabling the whole thing or just parts of it? Below is a copy of my untouched [autopilot] configuration file.

 

[autopilot]

autopilot_available= 1

flight_director_available= 1

default_vertical_speed= 1800.0

autothrottle_available= 1

autothrottle_arming_required= 0

autothrottle_max_rpm = 90

autothrottle_takeoff_ga= 0

pitch_takeoff_ga = 8;

max_pitch=10.0

max_pitch_acceleration=1.0

max_pitch_velocity_lo_alt=2.0

max_pitch_velocity_hi_alt=1.5

max_pitch_velocity_lo_alt_breakpoint=20000.0

max_pitch_velocity_hi_alt_breakpoint=28000.0

max_bank=27,14

max_bank_acceleration=1.8

max_bank_velocity=3.00

max_throttle_rate=0.10

nav_proportional_control=11.00

nav_integrator_control=0.20

nav_derivative_control=0.00

nav_integrator_boundary=2.50

nav_derivative_boundary=0.00

gs_proportional_control=9.52

gs_integrator_control=0.26

gs_derivative_control=0.00

gs_integrator_boundary=0.70

gs_derivative_boundary=0.00

yaw_damper_gain = 1.0

 

(Posted by Eric Williams on 09-13-13)

My approach mode has always worked fine in the Lear45 with no modifications. I always catch the glideslope as per standard procedure (from below) hip APP and ALT kicks off when I intercept. Follows it right down no issue.

 

I highly suspect there is something with the method of approach/airport. I have done a heck of a pile of ILS approaches with no issue. Should be an easy fix I would think. Think basics of the control/functions have been fine for me for many years prior and post build.

 

(Posted by Eric Tomlin on 09-14-13)

Eric G, I highly suspect/suspected the same thing (method/procedure/experience). I've went through this with him and the only thing that I found from his description was that he was a bit fast IMHO but over-all was not too far off in method. I've suggested several different airports/ILS approaches as well.

 

(Posted by Greg Branch on 09-15-13)

I can vouch that it is not method. The problem is that it will capture the localizer fine, but will not follow the glideslope down. Essentially what is happening is when you select approach mode, once it establishes, the altitude hold does not disengage and hold the aircraft at the pre-selected altitude. This is not how the aircraft should behave and it has nothing to do with the pilot(s).

 

(Posted by Ron Rollo on 09-15-13)

Since my last post, I have tried a couple different airports including Orlando International and still no luck. It is as if the glideslope is not there or it is being ignored. Although I can see the glideslope indicator moving so I know it is there.

 

So back to my question, to disable the AP in my configuration file, is it just a matter of throwing a couple // in front of the [autopilot] or something more to it? Disabling the AP seemed to do the trick for Jaap.

 

(Posted by Eric Williams on 09-15-13)

Absolutely bizarre how our identical FSX aircraft can have so different problems. I can vouch for it being a bit finicky when transitioning to follow the glideslope. The more I thought about this the more I was baffled.

 

Upon some thought and a few flights on my desktop rig, I was able to capture glideslope no problem but I realized I may be avoiding an issue somewhat. Are you hitting APP to use the localiser before you are close to glideslope intercept? I NEVER use APP for localizer. For this I use NAV. Once I see the glideslope indicator alive, then I hit APP (never before). Pretty sure this is the right way. A couple test runs on my desktop showed zero success when hitting APP before the glideslope is alive. Simply would never attempt to follow it down.

 

(Posted by Ron Rollo on 09-16-13)

Hey Eric G., so far every test flight I have done has been below glideslope and attempting to be as slow as practical. I wait until the GS comes alive and select APP. Nothing.

 

I'm going to email Jaap to have him throw his two cents in. He started this!

 

(Posted by Jaap on 09-16-13)

Hello my friends, Otto and I are still enjoying our cockpit and doing very little building lately. Other things are drawing my hobby money to the drain but we do a fly every week!

 

Since this topic has been resurrected, I have been following it with interest to see if anyone is able to find the cause of this strange problem. Since I started this post, I switched to P3D but found too many problems with it in my Sim, so I went back to FSX. This meant a full new and fresh installation of all the software I run on my main FSX PC, including Windows7. Since then I [u]never[/u] had the problem ever again. So there's no wise words for me to say because I don't have the solution. Except maybe a reinstall?  I wish you guys all the knowledge to bring this to a good ending! I'll be following the topic!

 

(Posted by Greg Branch on 09-16-13)

I believe that this is a simple programming/software issue, not a method issue. I won't go into "proper" methods, but in Ron's case, everything is as it should be when trying to use the autopilot to fly an approach.

 

I think if we dive into the config file or the software we will find our issue, we just didn't get the time while I was down there.

 

(Posted by Ron Rollo on 09-26-13)

Thanks Jaap for the clues. I will try to disable the AP like you suggested early in the thread. It is sad to hear that you tried Prepared3D and it did not work for you. Going to Prepared3D is something that I want to do just as soon as I see someone in our Lear group swear by it!

 

In the meantime, I did another test flight with the AP in the configuration file disabled. All that did was disable the AP. Imagine that!

 

UPDATE:

I apologize for not posting this information sooner but back on 08-30-14, I solved my AP APP issue. My problem was I did not have both offsets assigned to the APP button on the FGC.

 

First, I was using the FSUIPC offset "AP Approach Hold" 0800. Using this offset by itself you would think it would take care of all aspects of the approach hold but all it was doing was holding the approach heading. After doing a search from one end of the FSUIPC offset list to the other, I found this:

 

FSUIPC offset "AP Glide Slope Hold" 07FC

 

Apparently this is something that everyone either knows about and it is so elementary that no one thought to mention this or it is not widely known to use it. Not sure which but in my case using FSX, it is a MUST to have this second offset assigned to the APP button on the FGC. Maybe it was not needed in FS9.

 

NOTE: At the time I was using FSX and offset 07FC resolved my issue. I am now using P3D 2.4 and I am still using this offset so I am not sure if this offset is needed or not in P3D. I would say it is needed.

 

To recap: Jaap's original post back in 12-28-10, he was having an issue getting the auto throttles to work properly and he could not get his APP glide slope to hold. As Eric T. pointed out, the Lear45 does not have auto throttles. (Jaap has built a hybrid simulator that has features that are not found in the Lear45, one being "auto throttles". Cool feature by the way!) His other issue with the APP glide slope hold was apparently corrected with a reinstall of FSX after giving P3D a try and not being happy with it. I will reach out to Jaap to see if he is using FSUIPC offset 07FC.

 

In the meantime, if anyone is still having issues with the AP APP hold, please let us know!

 


Comments are closed, but trackbacks and pingbacks are open.